Jump to content
VWatchie

Mostly Russians, and few Japanese and Swiss

Recommended Posts

Careful examination of the stub of "gold" to the left might give some clues. It looks as though there was a metal tab attached to that, and floating on that plastic washer, but that may now be missing.

If you had another mech to compare, obviously that would be a help.

Maybe try a small copper wire screwed to that left hand screw and placed on top of the plastic washer, then refit the battery and see if it springs to life.

Share this post


Link to post
Share on other sites
Thanks Andy, I can’t see any pics ?


Sent from my iPhone using Tapatalk

I see it now it’s just come through on my phone


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Also take a look at this pic. of a similar mechanism.

I suspect that Timpsons are fitting the battery incorrectly.

The left hand screw/gold plate, needs careful cleaning, and the right hand tab needs fitting *UNDER* the battery, but above the plastic washer, and insulated in such a way that it doesn't short out the cell at the edge, so perhaps it just needs bent correctly to be recessed in at the right hand side of the battery holder to avoid contact with the edge of the battery. In other words the +ve of the battery looks to be connected to the left hand contact, and the -ve appears to be connected to the right hand contact (avoiding shorting things out in the process). The cell is an SR920SW, which are cheap as chips.

 

600x615xpoljot_quartz_1980s4.jpg.pagespeed.ic.TTlml-5PBX.jpg

Share this post


Link to post
Share on other sites
One more point. If they fitted a new battery, and shorted it out, then it is probably dead  by now, so test it with your multimeter, and if it is weak, replace it.

Thanks Andy


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On ‎1‎/‎5‎/‎2019 at 6:58 AM, BUSAKAZ said:

Hi Andy thanks for the advice I’ll give it a go when I get a min and report back.

Thanks Kaz


Sent from my iPhone using Tapatalk

Hi all an update, after completely stripping the movement it was completely covered in battery gunk so put the parts in the cleaner and new battery and all is well :thumbsu:

Share this post


Link to post
Share on other sites

Thanks for the update. Glad it is now working. :biggrin: Can we expect to see it in all its glory in "Watch of Today" it would be nice to see it face up with a decent strap on it.

Edited by AndyHull

Share this post


Link to post
Share on other sites
Thanks for the update. Glad it is now working. :biggrin: Can we expect to see it in all its glory in "Watch of Today" it would be nice to see it face up with a decent strap on it.

cb5c361b881eecd81dc825ce221892bd.jpg

Here it is



Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I've now been wearing my red and black radio room Amphibia/Albatros (first picture of the first post in this thread) for exactly one month since I last regulated it (Vostok cal. 2409 manual). December 27th it was 29.5 seconds late, and today it's 32.5 seconds late. It has lost three seconds in a month! It's been a long time since I wore a quartz watch, but as I remember it, those weren't much better than that over time. Of course, it largely depends on how the watch is worn, stored and wound, but nevertheless, I'm "blown away"! Who said Russians weren't up to the Swiss!? ;)

Share this post


Link to post
Share on other sites
1 hour ago, JBerry said:

In Bulgaria for a week, thought you might like to see my haul to date :)

 

 

 

Beautiful watches and I believe I see a theme! Thanks for sharing!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing

    No registered users viewing this page.

  • Topics

  • Posts

    • Hi All I'm a beginner.  I've finally competed my Seiko 6119A in a Seiko 5.  I now notice that the second hand tube is quite long.  It's not sliding down the shaft with moderate pressure.  How had should I push?  Is there a trick to this? Thank you    
    • Hello guys, I have some problem with my seiko 7015 speedtimer that i bought 2 days ago.. This seiko runs smoothly when chronograph off And when the chronograph is active,the watch runs for awhile and then stop.. Whats wrong with it and maybe you guys can help me with some solution please!! thanks
    • Hi Len thank you for the detailed reply. I tried a 329 today and unfortunately did not work. As you explained before it looks like the rotor is ocillating back and forth (the second hand moves forward and backwards).  Its heartbreaking to see as i was hoping to fix it and give back to my grandfather. is there anyway i can source the part or an alternative movement (does not have to be Omega) that will fit the dial and casing?Although not ideal as takes away from the integrity and beauty of the watch but would love to able to get it working one way or the other so my grandfather can wear it on the wrist again. any help would be much appreciated  regards   57253616986__A7C2CEC7-1ACC-483F-933C-D73C742B77C7.MOV
    • For what its worth, the watch would originally have looked more like this.
    • A little bit of a fun watch  for today's Watch of Today.

      Another Swatch rescued from the junk pile. This one had a couple of obvious issues.

      The leather band was filthy, heavily kinked, and stiff as a board. So much so that had to be scrubbed with detergent, dried, and some leather restoration work carried out. The watch itself however, as well as the usual heavily scratched crystal had an electro-machanical issue. When I popped in a brand new battery, the second hand would move for a bit, then falter. This turned out to be a combination of slight corrosion on the spring contact for the battery, and the fact that someone had previously run the watch with a tiny button cell, wedged in place with some scrunched up paper, which had bent the sprung battery contact.  A little very careful re-bending and off it went like a champ. This illustrates the point nicely, that even a little extra resistance in the battery contacts can be enough to stop a quartz movement, or make it behave erratically. The band took a little more effort. Once dried, following its bath, it became obvious that the original uniform kid leather look was long gone, so I went for a more vintage finish, with a little blending of the very worn patches using the leather dye in some dark tan shoe polish, combined with some lighter "Clarks Shoes" branded leather restoration cream. I only needed a hint of the dark tan, since I didn't want to end up with a brown shoes effect, simply to shine up the worn patches, and blend them with the existing colour.

      Several thin coats of leather cream mixed with a little dark tan, and much buffing later and the strap is back to its original soft calfskin feel, rather than dry as a stick. All of the holes are the same size again. The band forms a gentle curve, rather than being corrugated, and the stitching is clean.  The band looks ten times better than when it arrived. This is yet another member of the "404 Club", since it was effectively free with a bunch of other junk, I picked up which was purchased because it included a mechanical watch that I have yet to restore, all for under the magic £4.04
×