Jump to content
  • 0
Albert

Quartz Watch Not Starting After Battery Change

Question

Hello!

 

I took my trusty Swiss Army Watch (24221) to an electronics store for a battery change, and they tried a battery that was a hair too thick, then one that was too thin, before we found the proper size (Renata 371 in case anyone has the same problem). However, the watch did not spring back to life. It had worked fine prior to the battery change (except that it was signalling low voltage with that jumpy sweep of the second hand every few seconds). Also, I was present for the whole procedure and didn't see any undue handling or any insulators falling out or anything that could explain it not restarting.

 

 

Does anyone have an idea what the problem could be? I'd prefer not to throw out one of my favorite watches if there is still something that can be done, or at least know how to verify that it is really dead. I read that sometimes the "gears have to be spun" to resuscitate the movement, and that this can be done physically or magnetically. How is that done?

 

I'd appreciate any advice from the highly skilled readership here!

Cheers!

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I think this is an FE movement. There is a positive contact (the one you slightly unscrew to release the battery). and obviously a negative contact. Make sure the battery is not upside down. The writing on the battery should be facing upwards.

 

The second thing to look for is to make sure the battery isolator is not missing. This, I think, is orange in colour and resides between the lower negative contact - between the negative contact and the lower plate. If the negative of the battery is in any way touching the metal plate of the watch movement (e.g. if the isolator is missing) then the battery will be shorting and the watch will not work.

 

Isolators can easily be overlooked when removing the battery and a less experienced technician will not realise it was there in the first place.

 

I hope this helps.

Share this post


Link to post
Share on other sites
  • 0

I'd take it to someone else myself, if he was fiddling around with different batteries, he was rubbish & didn't  have a clue! if you take it to the right person they can

 

A. make sure the battery is in properly.

B. do a simple test to see if the movement is running electronically.

C. use something like a witschi cyclonic to clear any debris from the train.

D. diagnose & fix what everys gone wrong!

Share this post


Link to post
Share on other sites
  • 0

I think some of the (maybe older?) movements need a reset after a battery change. I remember doing it once but it was so long ago I don't even remember the procedure. I believe some section needs to be shorted or something.

 

Recently I had my neighbor watch for a battery change. After replacing with the correct battery number the watch wouldn't run. It checked Ok in the tester (good coil, pulse) and then I dropped it accidentally....when I picked it up it was running again. Please, don't try that at home!

 

Robert

Share this post


Link to post
Share on other sites
  • 0

then I dropped it accidentally....when I picked it up it was running again.
 
 

 

C. use something like a witschi cyclonic to clear any debris from the train.

 

Or drop it! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By kristofwanderer
      Hello,
      I recently reacquired a watch I had swapped off to a friend years ago, a Seiko 7t62-0am0 Asymmetry (I believe was the name).  The watch is a quartz movement and is a chronograph.  When I initially bought the watch (new) it was worn gently.  When I traded off the piece it was to a dear friend who tucked it away in a box and essentially forgot about it until recently.  I got the piece back a few weeks ago, had a battery installed at an AD and it worked normally.  After arriving home, I put on the watch and it was functioning normally, except it stopped after about 30 or so minutes.  I took it off thinking it was a faulty battery or connection, but when I looked at it the next day in the display case it was again working.  After repeatedly wearing the watch and removing the watch when it would stop, I have come to believe that my body heat is causing some metal part to expand, thereby making the watch stop.  Could this be the case?  If so, what exactly is the issue (i.e., which part is the culprit)?
      *the photo is a stock photo of this model watch*
      Thank you in advance for your assistance. 
      Respectfully, 
      Dr. C. King

    • By Bedford
      Got quite a peculiar one at the moment, and it's something that I've never personally encountered before.
      The clients watch is an Armani AR5905; he thought he needed a new battery and so here I am, 
      Upon taking the case-back off and placing a new battery in, I heard the circuit do the all so familiar whirring noise like it was springing back to life, however when I flipped it over it wasn't ticking.
      So I pulled the battery out and again put it back in, but what I noticed was that the whirring noise was only happening when the battery was halfway seated and thus not making full contact, and as soon as the battery was fully seated everything ceased. This time I put the battery in halfway and then flipped over the watch to see it working, and to my surprise the seconds sub-dial at the 6 position was spinning around wildly. However again stopped when the battery was fully inserted.
      Anybody have any ideas as to what is going on?
      I could upload a video if that would help.
    • By Ashnz
      Hello to all,
      My name is Ash (from NZ). Im a watch enthusiast and trying to learn more about Horology.
      I have been picking odd watch repair jobs here and there and self-learning.
      Firstly, thanks a lot to Mark Lovick for uploading fantastic videos on youtube that are so simple to follow. Keep up the great work
      Question - is there a way to diagnose quartz watch circuit using those test probes (that have an LED inbuilt) or perhaps using a multi-meter? For some watch movements such as Myota 2035, it makes sense to replace the whole movement. In other cases, it make sense to repair it (if possible).
      Is there a way to narrow down the faults in quartz watch? For instance, if a watch is gaining/loosing time, it could be the quartz crystal out of freq etc. how can it be scanned appropriately?
      Im not sure if its even possible or not. Hopefully I could get some help here.
      Thanks a lot in advance
      Ash
    • By Heman
      Hello all,
      I have a watch I would like to fix my self. It's made by TAWATEC, who is no longer in business. It's very similar to a Luminox and used TGS for lume. I will provide information to the best of my ability. 

      Here is a link to some information about it. Here are a few pictures of the watch. 

       


       
      I have had the watch since May of 2011. I had the battery replaced in Feb 2015 by a local shop. Less than a year later, I noticed that after taking a shower there was condensation under the crystal. I pulled the crown and left it sit to air out. After about a week I pushed the crown back in and the watch no longer worked. I wondered what caused it to leak. I then remembered I had to change the date on the watch a few days before condensation had got inside the watch. When I was trying to set the date I noticed that it was difficult to pull the crown out and it was more difficult to turn than usual. My guess was that the gasket/O-ring that is on the stem/crown was messed up and had ripped and water had entered that way. I left the watch sit for a year and used another watch as my daily driver. I'm hoping to get this one up and running again. So I recently decided to see if I could fix the watch myself. 
       
      Here is what I have done and have figured out so far...
      I was able to remove the case back by removing the 4 Phillips screws. Visually inspecting the O-ring that seals the case back, everything looks good. The movement is a Ronda 515. The plastic ring that holds the movement inside the case says Ronda 515 # 6. I was able to remove the crown and stem. Looking towards the inside of the crown there was remnants of the O-ring. After clearing the remnants and putting the crown back in, the crown moves freely. I also found remnants if rubber on the front of the dial. After inspecting the battery, it looks to have leaked its electrolyte What I would like to do first is replace the O-Ring that's on the crown and put a new battery in it. If I then determine that the movement is damaged, I can replace it later. 
      What do I need to do to figure out what size of O-ring I need for the crown? I can take pictures of the crown/stem if needed. I also have analog calipers to use that are in inches.
      Thanks for your time!
       
       
    • By watchnoob1
      Dear all,
      It's my first post here, please excuse if I post to the wrong sub-forum.
      I own a small collection of quartz and automatic watches and at least do most of the usual service myself.
      A friend of mine gave me an old watch she likes and asked me if I can change the battery. She told me it's around 25 years old and cheap but she likes the dial. It was a present by a french bank she worked for.
      All my watches are either press or screw down backs and I have never seen a watch like this. It seems that the only possible way to open the watch is the small plastic notch on the back. I tried to open it with quite some force but it didn't open.
      Do I overlook something, is there a special way to open it?
      I also got the original case. A note in it says in french that the battery is interchangeable.
      Already thanks for all your help!
      Best regards,
      Martin




  • Recently Browsing

    No registered users viewing this page.

  • Topics

  • Posts

    • "Philip head screws"   are very common and loads of timex dead watches out there for "a buck or two".  I did not know the screws came in metric and S.A.E..  vin
    • Unless you have another watch you can steal them from, it will be hard to say that they are "screw x". You should be able to get those from a normal fastener supplier though. You just need to know the thread pitch, diameter, and length of the screws. You can measure the thread pitch with one of these: https://en.wikipedia.org/wiki/Thread_pitch_gauge Note that metric and imperial systems measure screws differently of course, so if you're having trouble getting something that is exactly right, try using the other system. Googling around should get more details on getting the right measurements.
       
    • I have the above watch that has four small cross head screws holding the back of the case on. My question is that these look rather worn so where are places to get these screws and what measurements would be needed? The pic is not the actual watch but is the model. TIA Mike
    • .. on the other hand, there is the ETA 2893-2 automatic GMT for example... https://www.ebay.co.uk/itm/Authentic-ETA-2893-2-automatic-GMT-watch-movement-Victorinox/132919302254?hash=item1ef29b986e:g:KOMAAOSwuJRcG5Kj:rk:55:pf:0
×