Jump to content
  • 0

MST 521


Question

  • Could some one please tell me if I have the date jumper on this MST 521  up the right way. It flew away when I took the cover plate off. Managed to find it and the spring but might not be so lucky next time....Thanksp1010002.thumb.JPG.d87cbc089645ed1864758db72b0fd294.JPG
Link to post
Share on other sites

2 answers to this question

Recommended Posts



  • Recently Browsing

    No registered users viewing this page.

  • Topics

  • Posts

    • @Klassiker the AM220 is a good start, there's hints of this escape wheel cock and bridge shapes in the other larger AM movements on Ranfft as well
    • Not sure this will sent you in the right direction, but there is a chance 🙂 http://www.ranfft.de/cgi-bin/bidfun-db.cgi?10&ranfft&&2uswk&AS_278 Something somewhat similar..
    • You did not tell what was that "extra" screw for. I would do the following: - release the mainspring - remove balance bridge - remove pallet fork - rotate train wheels manually to confirm they move freely. If they don't - find out why. Once that is resolved or confirmed, next stem - replace the pallet fork, wind the main spring just few rotations, push the pallet fork gently to see if mainspring energy is being transferred and wheels are moving - just take a closer look at both pivots of the balance staff. Again, gently and without pulling too hard - check both pivot, top and bottom. You may have bent one while removing the balance bridge several times (i hope you did not). - with the mainspring wound, replace the balance bridge. Often balance would self-adjust (impulse jewel / fork) and start moving. Gently replace the balance bridge screw. Good luck!  
    • Valjoux 23/72 ... hadn’t been worked on in a long time.  Tore it down, cleaned it, reassembled - everything worked ... until I realized I left out a screw. Tore it back down, installed everything fully this time.  Balance wouldn’t rotate.  Gears seemed like they were seized. Tore it back down, spent a LOT of time on each assembly step, ensuring everything spun freely.  Installed the palate fork - flicked back and forth as appropriate.  Installed balance as the last step.  No rotation.  Spins freely when “encouraged”, but it doesn’t continue. I pulled it out.  Confirmed that the hairspring isn’t kinked.  Jewels look fine (no cracks or chips).  I don’t have the means to check if the balance staff is bent, but the balance seems level and when I encourage some rotation, I don’t see any wobble. Any thoughts on what to check next? Thanks!
    • I installed the spring back inside the barrel yesterday and checked it this morning. The copper wire band is still holding. But now I have a new problem with this clock. The strike mainspring is going to break at the eye. Is it possible to cut off the end and cut a new eye or should the spring be replaced?
×
×
  • Create New...