Jump to content
  • 0
rduckwor

Elgin: Sluggish Pallet Fork

Question

Working on an Elgin 10/5, GR 673 for myself.  Came in running, I dis-assembled and cleaned.  The train runs very well, and the balance swings like a champ.  The pallet fork is very difficult to seat and when I <THINK> I have it seated, it is very sluggish.  It doesn't "flick" from post to post.  I have looked at both jewels under the microscope, they appear pristine.  I have looked at the pallet under the microscope, neither pivot appears damaged or bent.  I even tried a spare pallet from another 15/0 movement.  No joy.

 

What am I missing here?


Thanks,


RMD

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

OH:  I'm not sure I ever got the pivots seated.  I am going to try once again and will check end shake and make certain the pivots are in the jewels.  I have attempted to seat the pallet at least 10 time today.  what's that saying about doing the same thing over and over . . .


Thanks,

 

RMD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...