Jump to content
margolisd

My First Omega Service

Recommended Posts

I was really pleased with this service and it's the first time I've worked on an Omega. It was a 1030 movement from the 70s with a broken mainspring. It looked like it hadn't been serviced in decades. Terrible reading as you can see. It was really nice to work with compared to the scrap I'm usually trying to rescue! I cleaned it, oiled it, replaced the mainspring and regulated it and just look at the difference! And it's within 10 seconds in all positions. Just made me happy so thought I'd share :)

 

IMG_1424.thumb.jpeg.f298876724e5467bc059ba7009493e29.jpegIMG_1459.thumb.jpeg.6593e32d515751d7457f9b2b5a62adca.jpeg

Share this post


Link to post
Share on other sites
3 hours ago, margolisd said:

Yes, you should fix it! Have you tried polishing the pivots? A bit of jeweller's rouge and clock oil on some peg wood works wonders for me!

I think you have convinced me. It may be a while before it gets back in the queue, but I'll take another look. I suspect, since it runs fairly well otherwise, that the issue is a tired mainspring. We will see.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...