Jump to content

Search the Community

Showing results for tags 'rolex1570'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • WATCH REPAIR DISCUSSIONS
    • Watch Repairs Help & Advice
    • Your Walkthroughs and Techniques
    • Showcase Your Achievements
    • Watch Repair Tools & Equipment
    • Watch or Horology Related Videos
    • Clock Corner
  • WRT LOUNGE
    • WRT News & Announcements
    • Introduce Yourself Here
    • Your Watch Collection
    • Chat About Watches & The Industry Here
    • Relax Zone: Chat About Anything Here
    • Help & Support With This Website
  • WATCH REPAIR TUTORIALS & INFORMATION
    • Watch Repair Course
    • Watch Parts and Tools Suppliers
    • Resources and Articles

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. Hi again forum amd watch lover. I have some problem with the upper bridge, the jewel seem lose and the bridge doesn't grip the jewel, (pic form internet) cause the rotor to have a nosey sound when shaken,by the way the oscillating staff still fit in the jewel. Any thing I can do about this ?
  2. Hi everyone ! I got a very strange problem after cleaning the movement 1570, the amplitude are good at 280~300 . 10 min later it drop around 130~170 and then it go back up to 280 again for a while, sometimes it completely stop. I did manually clean the jewel and all the cap jewel, the problem seem remain.Thanks for your time !
×
×
  • Create New...