Jump to content

Search the Community

Showing results for tags 'etachron'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Watch Repair Tutorials & Information
  • WRT LOUNGE
    • WRT News & Announcements
    • Introduce Yourself Here
    • Chat About Anything Here
    • Chat About Watches & The Industry Here
    • Your Watch Collection
    • Help & Support With This Website
  • WATCH REPAIR DISCUSSIONS
    • Your Projects, Walkthroughs and Techniques
    • Watch Repairs Help & Advice
    • Watch Repair Tools & Equipment
    • Watch Repair Gallery
    • Clock Corner
  • OTHER RESOURCES
    • Watch Technical Data & Service Sheets
    • Watch Repair Videos
    • Directory of other Horology related websites

Categories

  • Watch Repair Basics
  • Balance & Escapement
  • Watch Movement Servicing & Stripdowns
  • Quartz Watch Repairs & Service
  • Fitting Watch Jewels
  • Machining & Turning
  • Clock Repair Videos

Categories

  • Watch Movement Servicing
  • Watch Repair Techniques

Categories

  • Watch Servicing & Repair
  • Clock Servicing & Repair
  • Watch & Clock Making Books
  • Other Horology Related Books

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I'm having some unexpected behaviour from a eta 7750 that I'm trying to regulate after servicing. I went through service procedure using correct lubricants. Everything went fine. Actually I have some doubt on lubrication of incabloc wich I'm not sure I did correctly since I'm afraid that too much oil was placed in one of the two stones. The fact is that when I finished I wasn't brave enough to clean and lubricate it again ... shame on me but I felt that task to be very very difficult. Anyway after reassembling the watch I had it at my wrist for a week and it showed a great consistency at -10 sec a day. It'a stop grade movement and resting at night in DU, DD 9UP and 3UP positions always showed something between -14 -6 I was very happy with that result and I thought that a little regulation would have brought it to a very fine time keeping. Then I reopened the caseback and slightly moved etachron arm, that was resting in a nearly neutral position, in the + direction. Nothing happened (measuring with timegrapher open source app) Did it again, another slight push. Nothing ? ok I must have gone the wrong direction, then pushed all the way toward - Nothing happened. Ok this is annoying, all the way toward + nothing here I am, what I'm I missing? How come moving the regulator arm from - to + does not make any variation? I'm lost
×
×
  • Create New...