Jump to content

Search the Community

Showing results for tags 'eta2892'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Watch Repair Tutorials & Information
  • WRT LOUNGE
    • WRT News & Announcements
    • Introduce Yourself Here
    • Chat About Anything Here
    • Chat About Watches & The Industry Here
    • Your Watch Collection
    • Help & Support With This Website
  • WATCH REPAIR DISCUSSIONS
    • Your Projects, Walkthroughs and Techniques
    • Watch Repairs Help & Advice
    • Watch Repair Tools & Equipment
    • Watch Repair Gallery
    • Clock Corner

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi all I just recently finished servicing two Omega Speedmaster Reduced (equipped with the ETA 2892-A2 coupled with chrono module Dubois D├ępraz 2020) for a couple of friends and both watches are having the same issue. I'm an amateur and just service watches for family and friends. The automatic work is not fully winding the movement and both watches are stopping after 6 days of use. Very curious that the two watches are showing exactly the same behavior!! I have tried everything and I'm not being able to get the automatic work to wind the watches for long period of time without the need to give it a manual wind. What else can I do? People wearing the watches are quite active and don't have the same issue with other automatic watches. See below a measure of the timegrapher for 6 days of wearing the watch without manual winding (except for first day): Rate Amplitude Day 1 (full manual winding) +20 299 Day 2 +13 280 Day 3 +7 261 Day 4 -23 238 Day 5 -12 211 Day 6 Stopped Some info regarding the service: - All parts were carefully washed and carefully oiled as per ETA technical chart - Replaced mainspring with new one ordered from Cousins (GR25341X). I measured both new and old mainsprings and they are they are the same - Replaced reversing wheel with new one ordered from Cousins - Checked the oscillating weight and bearing and all seems fine. There is not looseness and it all seems very aligned and in place - Oiled the oscillating weight bearing with 4 very small drops of Moebius 9010 on 4 of the metal spheres (don't have much experience on this one, hope it is ok) - All the automatic work seems to work perfectly when I manually tested the rotation of the oscillating weight with the movement out of the case Only thing I did not replace yet is the bearing of the oscillating weight. I'm reluctant to do so since current one seems to be just fine and I don't to want spend money for a part that seems to be just fine. What else can I do? Many thanks
×
×
  • Create New...