Jump to content

Search the Community

Showing results for tags '7t62-0am0'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Watch Repair Tutorials & Information
  • WRT LOUNGE
    • WRT News & Announcements
    • Introduce Yourself Here
    • Chat About Anything Here
    • Chat About Watches & The Industry Here
    • Your Watch Collection
    • Help & Support With This Website
  • WATCH REPAIR DISCUSSIONS
    • Your Projects, Walkthroughs and Techniques
    • Watch Repairs Help & Advice
    • Watch Repair Tools & Equipment
    • Watch Repair Gallery
    • Clock Corner
  • WATCH REPAIR LESSONS
    • Patron Announcements & Chat
    • Premium Videos
  • OTHER RESOURCES
    • Watch Technical Data & Service Sheets
    • Watch Repair Videos
    • Directory of other Horology related websites

Categories

  • Watch Repair Basics
  • Balance & Escapement
  • Watch Movement Servicing & Stripdowns
  • Quartz Watch Repairs & Service
  • Fitting Watch Jewels
  • Machining & Turning
  • Clock Repair Videos

Categories

  • Watch Movement Servicing
  • Watch Repair Techniques

Categories

  • Watch Servicing & Repair
  • Clock Servicing & Repair
  • Watch & Clock Making Books
  • Other Horology Related Books

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello, I recently reacquired a watch I had swapped off to a friend years ago, a Seiko 7t62-0am0 Asymmetry (I believe was the name). The watch is a quartz movement and is a chronograph. When I initially bought the watch (new) it was worn gently. When I traded off the piece it was to a dear friend who tucked it away in a box and essentially forgot about it until recently. I got the piece back a few weeks ago, had a battery installed at an AD and it worked normally. After arriving home, I put on the watch and it was functioning normally, except it stopped after about 30 or so minutes. I took it off thinking it was a faulty battery or connection, but when I looked at it the next day in the display case it was again working. After repeatedly wearing the watch and removing the watch when it would stop, I have come to believe that my body heat is causing some metal part to expand, thereby making the watch stop. Could this be the case? If so, what exactly is the issue (i.e., which part is the culprit)? *the photo is a stock photo of this model watch* Thank you in advance for your assistance. Respectfully, Dr. C. King
×